how to setup scrollRight

Jan 15, 2012 at 4:50 PM

Hi,

I changed the Transition Effect(s) from fade to scrollRight, but I was not able to make the scrollRight work. Can you please guide me how to configure the scroll right. What other settings do I have to change?

 

Cheers

 

Coordinator
Jan 18, 2012 at 1:04 AM

The transition effects should work as long as there aren't any compatibility issues with any modules on the page, or the skin itself.  For example, the transitions don't work with the DarkKnight skin that ships with DNN.  These compatibility issues include: multiple jquery, jqueryui, cycle jquery plugin, and jquery easing references.  Any of those will conflict and not allow the transitions to work properly.  

You can determine if this is the case by using any web developer inspector tools in your web browser.  For example, Chrome has one that's built-in and can be used by pressing <Ctrl>+<Shift>+<I>, and you can use Firebug as well.

Outside of this, any of the supported transitions should work fine.

Feb 2, 2012 at 9:26 PM

Below is the error message that I am getting. The only other javascript running on the page is with the DNN Menu.  I can get the module to work as long as I have the Transition Effect set to Fade, but when I choose anything else it does not work.  Does this mean that on any page where you have the DDRmenu that you cannot choose a transition effect other than Fade? Or am I missing something?

[cycle] 1 - img slide not loaded, requeuing slideshow: http://www.arukor.com/Portals/0/Images/SaintJohn.png 0 0

jquery.cycle.min.js:10[cycle] 2 - img slide not loaded, requeuing slideshow: http://www.arukor.com/Portals/0/Images/SaintJohn.png 0 0
jquery.cycle.min.js:10[cycle] 3 - img slide not loaded, requeuing slideshow: http://www.arukor.com/Portals/0/Images/SaintJohn.png 0 0
40event.layerX and event.layerY are broken and deprecated in WebKit. They will be removed from the engine in the near future.
jquery.cycle.min.js:10[cycle] 4 - img slide not loaded, requeuing slideshow: http://www.arukor.com/Portals/0/Images/SaintJohn.png 0 0
26event.layerX and event.layerY are broken and deprecated in WebKit. They will be removed from the engine in the near future.
jquery.cycle.min.js:10[cycle] unknown transition: shuffle ; slideshow terminating

796event.layerX and event.layerY are broken and deprecated in WebKit. They will be removed from the engine in the near future.


Coordinator
Feb 3, 2012 at 4:58 AM

Judy,

What you describe is indeed the known conflict issue.  This issue prevents the additional transitions from working due to one of two reasons: (1) the JS error prevents the addition prerequisite scripts from loading; (2) the additional scripts are already on the page. 

There are a lot of scripts loaded by DNN and nearly every skin or module, so there must be more than just the DDRMenu scripts loading.