Content Slider 01.03.01 & DNN 8.0.3

Sep 20, 2016 at 8:08 PM
After an upgrade to DNN 8.0.3 & module update to 1.3.1, transitions stopped working. jquery.cycle.min.js throwing an error detecting browsers. Any suggestions?
Oct 27, 2016 at 2:30 PM
The JQuery version 1.9 has drop "$.browser" variable you have to add this script in ViewSlider.ascx of module (developer option from DNN in edit page mode) :


<script src="http://code.jquery.com/jquery-migrate-1.0.0.js"></script>


Like this :

<%@ Control Language="vb" AutoEventWireup="false" CodeBehind="ViewSlider.ascx.vb" Inherits="WillStrohl.Modules.ContentSlider.ViewSlider" %>

<asp:PlaceHolder ID="phSlider" runat="server" />
<asp:PlaceHolder ID="phScript" runat="server" />
<% If CanAppendSlidersAndScript() Then %>

__<script src="http://code.jquery.com/jquery-migrate-1.0.0.js"></script>__

<script language="javascript"type="text/javascript">/<![CDATA[/
(function ($, Sys) {
    function setupDnnSiteSettings() {
        initWnsContentSlider<%=TabModuleId %>();
    }

    $(document).ready(function () {
        setupDnnSiteSettings();
    });

    $(window).ready(function() {
        setupDnnSiteSettings();
    });

} (jQuery, window.Sys));
/]]>/</script>
<% End If %>